ObjectDock and Wildstar (MMO)

By on July 12, 2014 9:23:44 PM from Stardock Forums Stardock Forums

Cullyn

Join Date 02/2006
0

I'm running Win 8.1 with a dual screen setup and I have ObjectDock running a simple 6 tab dock on the top of my secondary screen.  Strangely enough, the only issue I seem to have is when I run Wildstar, the new MMO from Carbine, in full screen on my main monitor I occasionally get knocked out of Wildstar and back to the desktop.  Now, the game isn't crashing, it's like I ALT-tabbed out.  If I click on the Wildstar icon in my taskbar I'm brought right back into the game with no issues.  If I'm playing the game though this happens quite often.  If I close ObjectDock however, this doesn't happen at all. 

At first I thought ObjectDock was simply triggering it's "show" function because I had it originally docked to the right side of my primary monitor.  That's why I moved it to my secondary monitor but it hasn't seemed to help.  This isn't a gamebreaker or anything like that, but it is a bug I'd like to see fixed cause it's a pain to have to close out of ObjectDock any time I play the game.

Suggestions welcome!  Thanks all.

7 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
July 14, 2014 8:14:37 AM from Stardock Forums Stardock Forums

What settings do you have for ObjectDock as far as, Auto-Hide, Regular, Always on top?

Reason for Karma (Optional)
Successfully updated karma reason!
July 15, 2014 6:22:06 AM from Stardock Forums Stardock Forums

I do have it set to Auto-Hide and as I do have the second screen now was considering dropping that for the most part.  I had the same thing happen on another game, Really Big Sky, running through Steam as described above so it doesn't seem to be game specific.  That said, I can't be sure that it's happening on all the games I play.  I moved into a new house a couple of weeks ago and that's when I got the second monitor and this didn't start happening until the second monitor came into the equation so it likely has more to do with that than anything.

Full settings from the software:

6 tabs, position: top edge of screen, size: 48 pixels tall, style: Carbon tabs, effect: grow effect (no reflection), accessibility: In the background (regular) with the check on show dock when mouse is over dock, medium delay.

Happy to answer any other questions and appreciate the assist.

Reason for Karma (Optional)
Successfully updated karma reason!
July 15, 2014 12:40:29 PM from Stardock Forums Stardock Forums

Can you send in a support ticket, maybe mention this forum post too so we can take a look at it closer?

http://esupport.stardock.com/index.php?/Tickets/Submit

 

Reason for Karma (Optional)
Successfully updated karma reason!
Sign Up or Login and this ad disappears!
There are many great features available to you once you register. Sign Up for a free account and browse the forums without ads.
July 15, 2014 1:22:44 PM from Stardock Forums Stardock Forums

Done and done.

Reason for Karma (Optional)
Successfully updated karma reason!
August 23, 2014 6:06:39 AM from Stardock Forums Stardock Forums

Speaking of a second monitor: when you enter a game fullscreen, your mouse cursor is not seen anywhere outside the maximized game screen, but it DOES sometimes move around even on a second display (activated or not and shutting the second one down completely does not solve this as the cursor virtually moves around in the background still). When the "invisible" cursor is on the second screen instead your gaming screen and you click, you virtually click your desktop and the maximized application loses focus and minimizes, which explains what is happening to you.

Most games use a function (automatically or as an option) to "capture the mouse cursor" to that maximized application and stop it from also crossing its borders to another screen resultion in the problem you described.

If a game does not have such a function or option (like the first part of Dark Souls on PC did, were you even could visually see this second "virtual" cursor besides your crosshair ingame), you just can look for command line switches or a third paprty application like "http://www.snakebytestudios.com/projects/apps/cursor-lock/". Looking at the sites application description you most likely will see your problem described there.

Reason for Karma (Optional)
Successfully updated karma reason!
August 23, 2014 11:57:46 AM from Stardock Forums Stardock Forums

I'll give that a shot.  Sadly, support wasn't ever able to solve the issue and it probably as more to do with this scenario than anything that ObjectDock is specifically doing.  My thought is that when the cursor strays to the second monitor, it checks for auto-hide, and that minimizes my current game (it has happened in several at this point).  I've gotten in the habit of simply quitting out of ObjectDock when I'm going to play something but I'll see if this little tool helps out.  Thanks for the heads up!!

Reason for Karma (Optional)
Successfully updated karma reason!
August 23, 2014 12:28:05 PM from Stardock Forums Stardock Forums

No need to shut down any other program. Think of it as if you would have two windows open on the desktop; when one has focus and you click the other one, it loses focus to it. It is the same thing with maximized application and even the desktop, what you click becomes focused. In this case it also means that the desktop, which is also behind the maximized application, will be brought to top when focused (even accidently) what then forces the maximized application which was in front before the desktop to minimize as it cannot go anywhere else or just stay in the background like a normal window. This has to do with how Windows and its window manager priorotize things.

However, you are not alone with this. When looking at the link and getting morr information on the case, just search a bit and you will find enough threads with different solutions anywhere. When a game locks the mouse cursor correctly to its maximized window, what most do, this is no problem which explains why you haven't seen this with any game.

Another way would be setting a game to "borderless fullscreen", where it looks like maximized but behaves like a window. But this has two major drawbacks: a) only a few games (like WoW) have this option and it can lower performance seriously (as the hardware can throw in its full potential only when exclusively rendering to a screen – aka "fullscreen)!

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000187   Page Render Time:

Home | About | Privacy | Upload Guidelines | Terms of Service | Help
WinCustomize © 2014 Stardock Corporation. All Rights Reserved.