Stardock Closed for the Holidays
Jan 5, 2015 8:45

Stardock's offices will be closed in observance of the holiday season from December 19th until January 5th, 2015.

During this time there will be a delay in answering support tickets, so we ask for your patience during the holiday period.  While we will keep tabs on the tickets during the break, we will respond to them as quickly as possible upon our return.  

On behalf of the Stardock staff we wish you a happy holiday season and look forward to the new year!

Themes do not work with new firefox (v29.0.1)

By on May 13, 2014 6:34:37 AM from Stardock Forums Stardock Forums

luukvth

Join Date 01/2014
+1

With pretty much all the themes for WindowBlinds, the tabs in new firefox are unreadable. A few days ago my firefox got updated to version 29, and it has major interface changes. So now I wonder is this a theme problem, or a firefox problem, or windowblinds problem?

And how to solve this.

This is what I mean with 'tabs are unreadable':

 

This same problem occurs with numerous other themes.

I am using:
Windows 7 Ultimate SP1 x64
WindowBlinds 8.04 (025 - Windows 7 Edition) - 64 bit OS
Theme from screenshot: http://www.wincustomize.com/explore/windowblinds/8040/

13 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2014 6:51:02 AM from WinCustomize Forums WinCustomize Forums

Obviously it would be an impossible mission for the windowblinds devs to make sure it´s 100% compatible with every future update of any program / software etc.

My advise is to Exclude FireFox from being skinned in Windowblinds settings or simply change FF version or Browser completely 

Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2014 7:02:03 AM from Stardock Forums Stardock Forums

By the looks of it that's a theme issue.

It has a dark top part of a titlebar and then a lighter bottom area.

Other skins such as Corporate which comes with WB work just fine because they were designed with glassy areas in mind.

I wouldn't be shocked to discover they hardcoded black text for the inactive tab text though which if it is the case would be a firefox issue.  Their text becomes invisible on Windows 8 with the default OS theme if you set your frame colour to black too.

Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2014 10:05:21 AM from Stardock Forums Stardock Forums

I think it had something to do with the transparent tabs in firefox. Anyway I installed an addon called 'Classic Theme Restorer', that did the trick

 

So anyway this is a good solution for now. But we are talking about firefox here, not some 'any program/software update' neone6 was referring to. I dont know if im the only one here with this problem, but I guess WB needs to update in order to be compatible with the new firefox version which  about 25% of all people connected in the world are using to browse the web, dont you think so?

Reason for Karma (Optional)
Successfully updated karma reason!
Sign Up or Login and this ad disappears!
There are many great features available to you once you register. Sign Up for a free account and browse the forums without ads.
May 13, 2014 10:21:38 AM from Stardock Forums Stardock Forums

Quoting luukvth,

I think it had something to do with the transparent tabs in firefox. Anyway I installed an addon called 'Classic Theme Restorer', that did the trick



 

So anyway this is a good solution for now. But we are talking about firefox here, not some 'any program/software update' neone6 was referring to. I dont know if im the only one here with this problem, but I guess WB needs to update in order to be compatible with the new firefox version which  about 25% of all people connected in the world are using to browse the web, dont you think so?

As explained above, the problem is not WindowBlinds.

The theme you were using was not designed for glassy titlebars and the app unfortunately looks like it may have hardcoded black for text on inactive tabs.  This means no dark theme will work right with Firefox, but again that's not a WB issue, that's a design choice by the Firefox devs.

Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2014 4:10:08 PM from Stardock Forums Stardock Forums

I am using "Diamond" Stardock theme and after Firefox update buttons that close and minimize window disappear when browser is windowed:

 

Also some white edges appear on the sides.

I've excluded Firefox in WB settings but it only helped with fixing those buttons on fullscreen mode. Only changing the theme (some work, some don't) or unloading WB completely works on windowed mode.

Is there any way to fix this temporarily?

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2014 4:42:35 PM from Stardock Forums Stardock Forums

Quoting ViridianD,

I am using "Diamond" Stardock theme and after Firefox update buttons that close and minimize window disappear when browser is windowed:



 

Also some white edges appear on the sides.

I've excluded Firefox in WB settings but it only helped with fixing those buttons on fullscreen mode. Only changing the theme (some work, some don't) or unloading WB completely works on windowed mode.

Is there any way to fix this temporarily?

 

 

Under no circumstances must you exclude firefox from WB.  Doing so will break things as you have seen.

Make sure you are not using any custom firefox themes as they could impact things.  By the looks of it your firefox is not stock.

Generally speaking firefox is happiest with a theme with a titlebar that's not too tall.

Having checked here with diamond I see no issues with the titlebar buttons when maximized.  They appear just fine, though when maximized the black inactive tab text is a pain, but again that appears to be a poor design decision by the firefox team.

Edit: One option is to enable the titlebar option in firefox by right clicking the titlebar and picking customize and clicking the Titlebar button at the bottom left.

Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2014 6:16:32 PM from Stardock Forums Stardock Forums

Quoting Neil Banfield,

Edit: One option is to enable the titlebar option in firefox by right clicking the titlebar and picking customize and clicking the Titlebar button at the bottom left.


This actually worked, thanks a lot. Yeah i am using FT DeepDark theme because stock "Australis" (or w/e its called) theme is too bright and generally looks bad in my opinion

Unfortunately bottom part of the window appears completely transparent when titlebar and FT DeepDark are enabled which is also annoying. On the bright side - Australis and Diamond theme work fine together - i don't see any issues with inactive browser tabs.

Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2014 6:23:49 PM from WinCustomize Forums WinCustomize Forums

Quoting Neil Banfield,
Under no circumstances must you exclude firefox from WB.
Oops, my bad 

Reason for Karma (Optional)
Successfully updated karma reason!
May 26, 2014 3:03:29 AM from Stardock Forums Stardock Forums

 

I had an issue with Firefox 29.0.1 and Windowblinds 8.0.5 that seems to only creep up when I access the computer via logmein remotely.

 

Firefox would open but would be totally blank -- I could alt - key and access tabs and the url box but nothing would display.. I enabled the "title bar" this allowed firefox to 'render' and I could access the tabs opened and url box but the areas below the title bar where "clear" .. solution was to install a 3rd party theme on Firefox instead of default.

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
July 9, 2014 12:46:56 PM from Stardock Forums Stardock Forums

I haven't found any workarounds that will display the titlebar correctly; at least if I want to use my favorite Firefox and WindowBlinds themes.  For now, I reverted back to Firefox 28.

Does anyone know if Stardock is working on a patch that fixes this issue in the next WindowBlinds beta?

Reason for Karma (Optional)
Successfully updated karma reason!
August 12, 2014 9:49:54 PM from Stardock Forums Stardock Forums

Has anyone tried any of the newer version of Firefox yet to see if the problem is resolved?  I'm still stuck on Firefox 28.0

Reason for Karma (Optional)
Successfully updated karma reason!
August 17, 2014 4:58:16 PM from Stardock Forums Stardock Forums

Quoting MKANET,

Has anyone tried any of the newer version of Firefox yet to see if the problem is resolved?  I'm still stuck on Firefox 28.0

It has not been solved and it won't be solved until WindowBlinds get updated.

 

You have to enable titlebar then it will work with any firefox version but you won't get themed firefox titlebar of course.

Reason for Karma (Optional)
Successfully updated karma reason!
November 11, 2014 9:42:44 PM from Stardock Forums Stardock Forums

There is some sort of conflict between WindowsBlinds and Firefox!

Here's my workaround I was able to figure out that allows me to use WB & FF without missing the title bar window buttons.

 

This is Firefox version 33.0 with WindowBlinds version 8.06 on Windows 8.1 Pro 64Bit

 

Instructions:

0.) If you excluded Firefox in WindowsBlinds you should remove the exclusion as your skin will work with FF.

1.) Install Firefox add-on "Classic Theme Restorer"

2.) Create a file named "CTRpreferences.txt" and paste the data below into the file and save anywhere you want.

 

CTR_Preferences__DO_NOT_EDIT__'='->booleans__':'->strings__'~'->integers
tabs:tabs_squared
tabsontop:unset
ctabwidth~210
ctabmwidth~100
closetab:closetab_default
appbutton:appbutton_v2
appbuttonc:appbuttonc_orange
alttbappb=false
appbutmhi=false
appbutbdl=false
nbiconsize:small
smallnavbut=false
hidenavbar=false
backforward=false
wincontrols=false
starinurl=false
statusbar=true
hideurelstop=false
combrelstop=false
panelmenucol=false
verifiedcolors=false
findbar:findbar_default
nav_txt_ico:icons
ctab1:#00FF00
ctab2:#007700
ctabhov1:#FFFFBB
ctabhov2:#FFFF00
ctabact1:#FF8800
ctabact2:#FF0000
ctabpen1:#00FF00
ctabpen2:#007700
ctabunr1:#00FF00
ctabunr2:#007700
cntab1:#00FF00
cntab2:#007700
cntabhov1:#FFFFBB
cntabhov2:#FFFF00
ctabt:#000000
ctabhovt:#000000
ctabactt:#000000
ctabpent:#000000
ctabunrt:#000000
ctabtsh:#FFFFFF
ctabhovtsh:#FFFFFF
ctabacttsh:#FFFFFF
ctabpentsh:#FFFFFF
ctabunrtsh:#FFFFFF
tabcolor_def=false
tabtextc_def=false
tabtextsh_def=false
tabcolor_act=false
tabtextc_act=false
tabtextsh_act=false
tabcolor_hov=false
tabtextc_hov=false
tabtextsh_hov=false
tabcolor_pen=false
tabtextc_pen=false
tabtextsh_pen=false
tabcolor_unr=false
tabtextc_unr=false
tabtextsh_unr=false
ntabcolor_def=false
ntabcolor_hov=false
tabfbold_def=false
tabfbold_act=false
tabfbold_pen=false
tabfbold_unr=false
tabfbold_hov=false
tabfita_def=false
tabfita_act=false
tabfita_pen=false
tabfita_unr=false
tabfita_hov=false
highaddonsbar=false
hightabpososx=false
altmenubar=false
altmenubarpos=false
altmenubarpos2=true
menubarnofog=false
noaddonbarbg=false
notabfog=false
notabbg=false
nobookbarbg=false
nonavbarbg=false
nonavborder=false
nonavtbborder=false
alttabstb=true
cpanelmenus=false
bfurlbarfix=false
emptyfavicon=false
emptyfavicon2=false
hidezoomres=false
pmhidelabels=false
menupopupscr=false
hideprivmask=false
invicomenubar=false
invicotabsbar=false
inviconavbar=false
invicoextrabar=false
invicobookbar=false
invicoaddonbar=false
tabmokcolor=false
tabmokcolor2=false
tabmokcolor3=false
dblclnewtab=false
hidetbwot=false
faviconurl=false
padlock:padlock_default
dblclclosefx=false
hide_bf_popup=false
throbberalt=false
bmanimation=true
pananimation=true
closeabarbut=false
toolsitem=true
appmenuitem=true
contextitem=false
cuibuttons=true
padlockex=true
closetabhfl=false
noemptypticon=false
feedinurl=false
noconicons=false
closealt=false
closeonleft=false
hidetbwote=true
puictrbutton=false
hideprbutton=false
hidesbclose=false
athrobberurl:
bmarkoinpw=false
appbclmmenus=true
chevronfix=false
bf_space=false
tabc_hov_unr=false
tabc_hov_unl=false
iat_notf_vt=false
tabmokcolor4=false
am_extrabars~1

 

3.) In Firefox goto your add-on page and click on the option button for add-on "Classic Theme Restorer".

4.) On the Classic Theme Restorer config window click the bottom left button "Settings" and select "Import preferences".

5.) Now you need to point to your saved file "CTRpreferences.txt" and select open.

6.) Classic Theme Restorer is now configured!

7.) On the Firefox address field type    about:config    and enter.

8.) Confirm with the warning by clicking the button "I'll be careful, ..."

9.) A long list appears with all the internal settings of Firefox. Search for the preference name line "browser.tabs.drawInTitlebar". 

10.) The value has to be set to "false". You can double click on the line and it should change over to false.

11.) If you have FF menu bar turned on you might still see an issue with the background in that case you can turn off the menu bar and try using the icon "Open menu" next to the home button to get to your menu commands.

 

Hope this will help some of you dealing with WB with FF tabs and title menu bar not being displayed correctly.

Perhaps someone will find a solution for the menu bar line to show the correct color instead of being transparent.

 

James

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0001829   Page Render Time:

Home | About | Privacy | Upload Guidelines | Terms of Service | Help
WinCustomize © 2014 Stardock Corporation. All Rights Reserved.