Shadows problem

By on September 6, 2013 3:09:49 PM from WinCustomize Forums WinCustomize Forums

roflmfaoo

Join Date 12/2009
+48

I've never come across this before but it appears that there is an issue with the inactive dwm shadows around the per pixel frames.

 

I did check the margins to make sure that they're correct. Thanks in advance to anyone who helps me overcome this

14 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
September 6, 2013 5:30:36 PM from WinCustomize Forums WinCustomize Forums

Shadows you made?

 

Are the images for the frames stacked the same as the images for the shadows, horiz. or vert but matching?

 

Even if your margins are correct, the image has to be. I do not imply anything other than hoping it helps, but, maybe recheck the images , it is easy to miss something with transparent images.

Just suggestions, disregard anything you like or dislike since you may have done these things and I sound like I am insulting you.Not so. DT1

Reason for Karma (Optional)
Successfully updated karma reason!
September 6, 2013 7:15:06 PM from WinCustomize Forums WinCustomize Forums

I don't take offence don't worry . I appreciate any suggestion as to why this is happening. I have made several other blinds using the same technique of slicing the frames and merging each frame for the states into one image and then importing to SKS. The thing is it's fine with the active shadows only when the window becomes inactive that this happens. It just baffles me slightly. 

I changed the shadows and re-sliced and still the same problem.

Reason for Karma (Optional)
Successfully updated karma reason!
September 6, 2013 7:37:46 PM from WinCustomize Forums WinCustomize Forums

Perhaps because the shadow itself isn't being redrawn correctly due to size of the shadow itself? Couple of pixels short maybe. Just guessing.

Reason for Karma (Optional)
Successfully updated karma reason!
Sign Up or Login and this ad disappears!
There are many great features available to you once you register. Sign Up for a free account and browse the forums without ads.
September 7, 2013 2:24:30 AM from WinCustomize Forums WinCustomize Forums

Maybe some mixed up code. When you recut and reimported, did you delete the code and reimport with a slightly different name to the images, might help. Had to do this many times.

Reason for Karma (Optional)
Successfully updated karma reason!
September 7, 2013 10:56:48 AM from WinCustomize Forums WinCustomize Forums

yeah deleted the section and re-imported, changed margins etc.. should work fine but doesn't. I'll give the shadow size thing a try although it says that the max is 30px mine is a shadow size of 18px. 

edit:

Tried making the shadow smaller but the problem still appears. This is baffling . It's just the inactive state that this happens. I'm not sure what changes they made with windowblinds 8 but it appears to have done something. 

Reason for Karma (Optional)
Successfully updated karma reason!
September 7, 2013 11:34:38 AM from WinCustomize Forums WinCustomize Forums

ignore this, just testing

Reason for Karma (Optional)
Successfully updated karma reason!
September 7, 2013 3:21:42 PM from WinCustomize Forums WinCustomize Forums

In the SKS preview it's setup correctly and displays. But when applying the blind the inactive states mess up, specifically the top/bottom or left/right. I think it's the former rather than the latter but I am still unsure as to why this is happening since it doesn't do this on the active states.

top : Active state
btm: Inactive state

 

Reason for Karma (Optional)
Successfully updated karma reason!
September 7, 2013 4:16:44 PM from WinCustomize Forums WinCustomize Forums

Is there an advanced setting for the value of the corners and how they treat the very rounded edges?

 

Also, did not realize you were using 8, I am not, very well could be an issue with the program. Sorry I couldn't help. Good Luck.

Do, you still have the old version, roll back , make your shadows, reimport into the new interface maybe.

Reason for Karma (Optional)
Successfully updated karma reason!
September 7, 2013 4:35:24 PM from WinCustomize Forums WinCustomize Forums

I'm on windows 7 but updated to windowblinds 8 just to see what was new and to prepare myself for migration to windows 8 eventually at least for skinning purposes. I'll keep at it and see what's what. It's probably something stupid that's completely slipped my mind.

edit:

Okay, it appears that SKS has trouble viewing side shadows that have a higher height dimension than 320px. I resized the frames to 150px each and it works perfectly. Thanks for the suggestions .

Reason for Karma (Optional)
Successfully updated karma reason!
September 9, 2013 8:37:55 AM from WinCustomize Forums WinCustomize Forums

These tips come in handy.

Reason for Karma (Optional)
Successfully updated karma reason!
September 9, 2013 10:02:35 AM from WinCustomize Forums WinCustomize Forums

Glad you got it. Nice work figuring it out.

Reason for Karma (Optional)
Successfully updated karma reason!
September 9, 2013 10:04:50 AM from WinCustomize Forums WinCustomize Forums

Uvah,how come you did not know this!

 

 

Poor guy had to answer his own post to get a fix,lol.

Reason for Karma (Optional)
Successfully updated karma reason!
September 9, 2013 12:08:48 PM from WinCustomize Forums WinCustomize Forums

It's all in experience

Reason for Karma (Optional)
Successfully updated karma reason!
September 9, 2013 12:26:18 PM from WinCustomize Forums WinCustomize Forums

Quoting doortech1,
Uvah,how come you did not know this!

See reply #13

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108431  walnut1   Server Load Time: 00:00:00.0000266   Page Render Time:

Home | About | Privacy | Upload Guidelines | Terms of Service | Help
WinCustomize © 2014 Stardock Corporation. All Rights Reserved.