Objectdock "Always on Top" bug

By on July 12, 2013 11:17:39 AM from Stardock Forums Stardock Forums

TheBlueRaja

Join Date 02/2008
+1

Hi,

  I was wondering if you could help, I currently have Windows 7 x64 and objectdock, I have it set so that objectdock is configured so to be always at the top of my desktop screen, in addition I have “Always on Top” unchecked.

However I find that when I use a program in full screen mode, like Firefox or Outlook that Objectdock pops forward whenever I go to the very top of the screen, even though it should be behind the maximized window in front of it.

I seem to hit this quite a lot, especially when using Firefox and changing between tabs, so I’m wondering why this is happening and if I can stop it.

It annoys the hell out of me.

Any ideas?

12 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
July 12, 2013 11:53:08 AM from WinCustomize Forums WinCustomize Forums

Does it happen on any part of the edge of your screen or just where the dock is hidden?

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 8:26:17 AM from Stardock Forums Stardock Forums

Hi,

  If i understand you correctly, it only happens where the dock is.

So, to clarify, as mentioned i have the dock at the top of my desktop screen, centred.  If i then full-screen firefox (so objectdock is BEHIND firefox) and move my mouse right to the very top of the screen (only over the area where the dock would be behind) the dock immediately pops to the front (see included pic).

Its a pain in the butt when you use some programs like firefox as when you goto change tabs objectdock pops to the front and you end up launching some random program as opposed to selecting the tab you want because you drifted the mouse a bit to far to the top of the desktop.

Issue

 

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 11:19:58 AM from WinCustomize Forums WinCustomize Forums

I just needed you to clarify that. Its a normal function of ObjectDock. I run into that all the time as I'm sure most do. It can be a pain but nothing you can do. Sorry

 

 

EDIT:

I just took a closer look at your screenshot. Dude......you have how many icons on the dock? It stretches across the entire screen! Lose some of those icons, create another dock and put it on the left or right of your screen. There's your fix.

Reason for Karma (Optional)
Successfully updated karma reason!
Sign Up or Login and this ad disappears!
There are many great features available to you once you register. Sign Up for a free account and browse the forums without ads.
July 13, 2013 12:50:20 PM from WinCustomize Forums WinCustomize Forums

See reply #6.

 

 

 

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 12:52:00 PM from WinCustomize Forums WinCustomize Forums

Dunno why the text "Internet Explorer" stays on screen after the mouseover.

I'd guess it has to do with WinFX.

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 12:57:39 PM from WinCustomize Forums WinCustomize Forums

OK, my bad. I misread your intention. please check "keep on bottom".  Also, uncheck "show dock when mouse touches edge."

 

Or, you could just turn off ObDock, since you now can't access it anyway.       

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 12:58:57 PM from WinCustomize Forums WinCustomize Forums

Uvah, the number of icons has nothing to do with it.

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 1:33:12 PM from WinCustomize Forums WinCustomize Forums

Even with autohide selected it will still happen because of the size of the dock. Get too close and the dock will show. I just tested it on mine. It doesn't have to touch the edge. His dock is centered and runs the length of his screen. No matter where up top he goes.

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 1:38:59 PM from WinCustomize Forums WinCustomize Forums

Autohide isn't what he wants Ross, I misread. See reply 6. That is the answer.

Set yours that way,and you'll see.

As long as your FF ( or whatever window) is maxxed, you won't be able to access the dock..

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 1:41:33 PM from Stardock Forums Stardock Forums

Quoting Uvah,

Even with autohide selected it will still happen because of the size of the dock. Get too close and the dock will show. I just tested it on mine. It doesn't have to touch the edge. His dock is centered and runs the length of his screen. No matter where up top he goes.

Nope. also, there's nothing wrong with that many icons, that's just how i roll....

Quoting RedneckDude,

OK, my bad. I misread your intention. please check "keep on bottom".  Also, uncheck "show dock when mouse touches edge."

 

Or, you could just turn off ObDock, since you now can't access it anyway.       

Thanks RedNeckDude, your spot on, deselecting "Show dock when mouse touches edge" under the Accessibility submenu (Home Tab) was all i needed to do, talk about hard to find though.

Works an absolute treat now.

Thanks for your help, this has been bugging me since i started using Objectdock.

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 1:49:21 PM from WinCustomize Forums WinCustomize Forums

You're very welcome, TBR, glad I could help!

Reason for Karma (Optional)
Successfully updated karma reason!
July 13, 2013 2:38:29 PM from WinCustomize Forums WinCustomize Forums

Okay....my bad. 

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108431  walnut1   Server Load Time: 00:00:00.0000156   Page Render Time:

Home | About | Privacy | Upload Guidelines | Terms of Service | Help
WinCustomize © 2014 Stardock Corporation. All Rights Reserved.