Problem with WindowBlinds and TotalCommander

By on February 15, 2013 11:51:51 AM from WinCustomize Forums WinCustomize Forums

lzvk25

Join Date 10/2004
0

Now that I decided to change the look of my desktop and after a long time of using the same skin, I found that with many of the new skins I am having a problem with the right click in Total Commander.

To ilustrate my problem, here are these screenshots, first with one that works with no problems.

With Skin : Pressurized by Xiandi

First here is the regular Total Commander :

[URL=http://imgur.com/qgzg5nU][/URL]

Now, I do a right click with the mouse, and the corresponding right click menu appears :

[URL=http://imgur.com/p0Bo8At][/URL]

Now using a new and recently purchased Skin : Enticer by LightStar

Again, the regular Total Commander :

[URL=http://imgur.com/WPPrKdI][/URL]

And now, when I do the right click, the menu dissappears !!

[URL=http://imgur.com/d5y4c8v][/URL]

And this happens with skins from other authors. For example : Construct and Woodoku both by TomRichter

Out of curiosity, in SkinStudio, I noticed that the behaviour of the right click menu in Total Commander is not the same as is Windows Explorer, that's why the "skinner's" never find this issue. However since I am not a "skinner" I do not dare to modify it, unless I have proper instructions on what to do.

So, is this a bug or maybe a setting I need to change ?

And please, don't tell me that I have to exclude my Total Commander, if the "old" skins work perfectly, why not the new ones ?

And just in case, for what it is worth, here is my WindowBlinds Info :

Your computer has a Windows Experience Index base score of 5.9
Your Windows Graphics Experience score is 7

WindowBlinds version : WindowBlinds 7.42 (325 - Windows 7 Edition) - 64 bit OS

WindowBlinds is installed correctly on this PC
WindowBlinds appears to be activated on this PC
(Generic PnP Monitor) 1 is attached to ATI Radeon HD 5670
(Dell ST2010) 2 is attached to ATI Radeon HD 5670

Wblind.dll 2012/07/13 12:23:20
Wblind64.dll 2012/07/13 12:24:18
Wbsrv.dll 2011/09/26 14:10:56
SevenConfig.exe 2012/07/09 16:44:31
Wbload.exe 2010/10/20 15:08:35
Wbhelp.dll 2011/10/04 09:01:37
Tray.dll 2009/10/23 19:12:19
Wbload.dll 2010/06/07 14:59:25
Screen.exe 2010/06/07 14:59:43

17 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
February 15, 2013 12:06:55 PM from WinCustomize Forums WinCustomize Forums

You might try reapplying the skin.  Though not a technical response as to why this happens sometimes reapplying the skin clears things up like this.  Now if that doesn't work you could try uninstalling the skin, run a clean up program, reboot and then reinstall.  It might be that when you downloaded the WB something go messed up.  

If that doesn't work you might want to contact LightStar and have him look at your problem. 

Reason for Karma (Optional)
Successfully updated karma reason!
February 15, 2013 12:32:33 PM from WinCustomize Forums WinCustomize Forums

I re-applied the skin,  rebooted, etc. and nothing.

I already tried to contact the author (TomRichter) in the case for Woodoku but because that was the first case I found I couldn't see if this was a trend with the new skins. Obviously, he says that his skins works OK, and since most likely he doesn't have to deal with Total Commander, he is right.

Therefore, either is a setting or a bug somewhere... That's my gut feeling.

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 15, 2013 1:50:47 PM from WinCustomize Forums WinCustomize Forums

It may also be something as simple as a color of font that the skinner is using in that instance.

Reason for Karma (Optional)
Successfully updated karma reason!
Sign Up or Login and this ad disappears!
There are many great features available to you once you register. Sign Up for a free account and browse the forums without ads.
February 15, 2013 5:13:05 PM from WinCustomize Forums WinCustomize Forums

Sorry you are having this issue with Enticer lzvk25, but I just checked the skins menu settings in image mode and flat menus, and everything works fine. I have no way of researching your issue as I do not use Total Commander either, and doubt if I could fix it unless someone with Total Commander that is also a WB skinner finds the problem. For the most part, it is not possible to create a WB that works perfectly on every application.

Reason for Karma (Optional)
Successfully updated karma reason!
February 16, 2013 4:01:49 AM from WinCustomize Forums WinCustomize Forums

Try closing Total Commander and reopening it again, if you haven't already done that. I sometimes encounter this issue with my graphics programs, getting a blank menu after clicking on the menu bar. Works every time. Not saying it will work here but worth a shot I think.

Reason for Karma (Optional)
Successfully updated karma reason!
February 16, 2013 11:37:47 AM from WinCustomize Forums WinCustomize Forums

Quoting Uvah,
Try closing Total Commander and reopening it again, if you haven't already done that. I sometimes encounter this issue with my graphics programs, getting a blank menu after clicking on the menu bar. Works every time. Not saying it will work here but worth a shot I think.

That was the very first thing I tried, and as I said before, I re-applied the skin, rebooted my machine, etc. and nothing.

This is an issue that only happens with Total Commander and the "new" skins.

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 16, 2013 11:55:42 AM from WinCustomize Forums WinCustomize Forums

Quoting LightStar,
Sorry you are having this issue with Enticer lzvk25, but I just checked the skins menu settings in image mode and flat menus, and everything works fine. I have no way of researching your issue as I do not use Total Commander either, and doubt if I could fix it unless someone with Total Commander that is also a WB skinner finds the problem. For the most part, it is not possible to create a WB that works perfectly on every application.

I think what LightStar said is probably the key.  The fact that older skins may work with Total Commander may have to do in part with those skinners using it and therefore it looks okay.  I'm not a skinner but I remember seeing threads here that would indicate if you make a WB work with a specific piece of software that it could very well mess it up for another.

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2013 9:50:09 AM from WinCustomize Forums WinCustomize Forums

Is there anybody from Stardock Support who could give us some insight about a possible cause ?

Please ?

Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2013 9:54:29 AM from WinCustomize Forums WinCustomize Forums

Funny thing is I downloaded and installed Total Commander to troubleshoot this issue on Windows 7 64-bit and did not have any issues at all with the menus like that as far as I could tell.  However, when I right clicked on a directory like shown in the screenshot in the OP (I am assuming that is what was done), I did not even get a menu popup at all. Maybe I was doing something wrong or did not have it configured correctly?

 

Other than that possibility, all menus in Total Commander with the Enticer skin applied are working perfectly.

Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2013 8:34:05 PM from WinCustomize Forums WinCustomize Forums

Quoting LightStar,
Funny thing is I downloaded and installed Total Commander to troubleshoot this issue on Windows 7 64-bit and did not have any issues at all with the menus like that as far as I could tell.  However, when I right clicked on a directory like shown in the screenshot in the OP (I am assuming that is what was done), I did not even get a menu popup at all. Maybe I was doing something wrong or did not have it configured correctly?



Other than that possibility, all menus in Total Commander with the Enticer skin applied are working perfectly.

 

That's right, I right clicked on a directory for the screenshots, and it should happen the same if you right click a regular file. And yes, everything else works fine, except that infamous right click menu.

 

Thank you LightStar for trying to debug this issue.

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 22, 2013 12:23:38 AM from WinCustomize Forums WinCustomize Forums

Lightstar: You have to click and hold the right mouse until the menu appears. Total commander still mimics the old Norton Commander / Treeview behaviour, which didn't use right click as context menu, if I remember right. In TC 'short' right click  is used to highlight an item.

Reason for Karma (Optional)
Successfully updated karma reason!
February 22, 2013 8:08:59 AM from WinCustomize Forums WinCustomize Forums

Thanks c242, I have never used any of those products so I'll give it another try to check it out.

Reason for Karma (Optional)
Successfully updated karma reason!
February 22, 2013 8:21:41 AM from WinCustomize Forums WinCustomize Forums

OK, just installed Total Commander version 8.01 again and everything, including those right click menus, work perfectly, nothing is wrong with any of the menus and not only did I check it with Enticer, but multiple other skins also. Sorry lzvk25, but it appears that this is a one of a kind problem just on your system.

Reason for Karma (Optional)
Successfully updated karma reason!
February 24, 2013 10:37:06 AM from WinCustomize Forums WinCustomize Forums

Thank you for your time, guys, however, I do not think the issue is on my side because if it was, ALL the skins would have the same problem, and yet I have a lot of old skins that work perfectly, even a lot of them designed for Windows 7. And as I said before, it is only the new skins that present this issue.

Therefore something changed and probably only Stardock Support can answer that....

 

 

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 24, 2013 10:58:17 AM from WinCustomize Forums WinCustomize Forums

Quoting lzvk25,
One last try. what version of Total Commander did you try ? The one I have is the 32 Bit version because of the plugins.

 

I used the latest 64-bit version, Total Commander v8.01.

Reason for Karma (Optional)
Successfully updated karma reason!
February 24, 2013 11:04:28 AM from WinCustomize Forums WinCustomize Forums

Quoting LightStar,

Quoting lzvk25, reply 14One last try. what version of Total Commander did you try ? The one I have is the 32 Bit version because of the plugins.

 

I used the latest 64-bit version, Total Commander v8.01.

I tried again with the 64-bit version, same result. Sorry.

I am going to write to Stardock Support, with a lot of luck maybe they will answer.

Reason for Karma (Optional)
Successfully updated karma reason!
February 24, 2013 5:41:32 PM from WinCustomize Forums WinCustomize Forums

I would imagine this has something to do with a combination of softwares installed on your system interfering with Windowblinds and/or Total Commander, and it involves your system only. I know it's a pain in the butt, but I think your only resolve will be to uninstall other software one at a time, not your major software, just the lesser known stuff, then rebooting and checking Total Commander again. I don't think Stardock Support will be able to help, but maybe they have heard of this problem before hopefully. I am really surprised no one from support has even commented on this thread, considering it has been here for 9 days now.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108431  walnut1   Server Load Time: 00:00:00.0000312   Page Render Time:

Home | About | Privacy | Upload Guidelines | Terms of Service | Help
WinCustomize © 2014 Stardock Corporation. All Rights Reserved.