Mess after change

By on June 13, 2011 4:01:01 PM from WinCustomize Forums WinCustomize Forums

c242

Join Date 03/2001
+82

Icon Packager clearly has a problem when updating Icon packs. Sometimes everything is completely messed up and no icon is where it belongs. Which I canÄ't understand as every icon 'only' has a fixed number. Should be no problem to keep these in order.

26 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
June 13, 2011 4:04:02 PM from WinCustomize Forums WinCustomize Forums

IconPackager 5.10.032 with Windows 7 SP1 x64 that is.

Reason for Karma (Optional)
Successfully updated karma reason!
June 13, 2011 4:13:36 PM from WinCustomize Forums WinCustomize Forums

You should avail yourself of Support's help, Carl. Maybe also note what other software is open at the time...?

Reason for Karma (Optional)
Successfully updated karma reason!
June 13, 2011 4:18:17 PM from WinCustomize Forums WinCustomize Forums

IconPackager doesn't seem to work right with Windows 7.

Reason for Karma (Optional)
Successfully updated karma reason!
Sign Up or Login and this ad disappears!
There are many great features available to you once you register. Sign Up for a free account and browse the forums without ads.
June 14, 2011 3:39:39 AM from WinCustomize Forums WinCustomize Forums

Best to make a ticket then, right ?

Reason for Karma (Optional)
Successfully updated karma reason!
June 14, 2011 3:59:23 AM from WinCustomize Forums WinCustomize Forums

Quoting WebGizmos,
IconPackager doesn't seem to work right with Windows 7.

Is that a common known problem ? I mean if such an essential function like updating and saving a package is broken, a fix would be in order.

System Requirements

Requires: Windows 7 / Vista / XP

 

Reason for Karma (Optional)
Successfully updated karma reason!
June 14, 2011 4:00:59 AM from WinCustomize Forums WinCustomize Forums

Ticket ID: SXH-324381

Reason for Karma (Optional)
Successfully updated karma reason!
June 14, 2011 7:13:16 AM from WinCustomize Forums WinCustomize Forums

Carl... If it's a matter of "blank icons" I did see a fix by JcRabbit on page 4 of the June 2011 desktop screenshot thread:

"Open the Windows Registry Editor, go to HKEY_CLASSES_ROOT\exefile\shellex and delete the subkey/folder IconHandler"

This did work for WebGizmos' blank icons.

If it's a wonky IP5 I'd also "Verify Installation" through Impulse. [select IP and then shift+right click]. 

Reason for Karma (Optional)
Successfully updated karma reason!
June 14, 2011 7:59:58 AM from WinCustomize Forums WinCustomize Forums

No, it is not the blank icons. It is when I change icons in a pack and save the package it can happen that for example .jpg extension files have the security shield applied as an icon or that .xlsx files have the .txt icon applied. All sorts of strange things also happen to other Icons also.

Another problem is that often the original app-icons get applied back when starting the application for that filetype. But that is not IPs fault. Adobe and Corel filetypes are good at that.

Other than that : 'Iconpackager is installed correctly.'

Reason for Karma (Optional)
Successfully updated karma reason!
June 14, 2011 8:15:43 AM from WinCustomize Forums WinCustomize Forums

Then it sounds like Support and the devs need to solve that problem, mate. Sorry I couldn't help. 

Reason for Karma (Optional)
Successfully updated karma reason!
June 14, 2011 9:05:54 AM from WinCustomize Forums WinCustomize Forums

No prob mate, I used ESupport.

Reason for Karma (Optional)
Successfully updated karma reason!
June 14, 2011 10:33:41 AM from WinCustomize Forums WinCustomize Forums

Quoting c242,
No, it is not the blank icons. It is when I change icons in a pack and save the package it can happen that for example .jpg extension files have the security shield applied as an icon or that .xlsx files have the .txt icon applied. All sorts of strange things also happen to other Icons also.
I've had that happen to be when I was building a package. I opened the builder, put a few in, saved it, closed it. When I reopened it and added a few more they got all messed up, like IP forgot which icons went where.

I've since been told that it's best to just put all the icons in all at once, not to close and reopen the builder while putting them in. That works for the most part, but even then, not all of the icons will apply ...or even show up in the preview window. And this 'solution' will not work if you only want to change a few in a pack once you've downloaded it.

Iconpackager is definitely in need of some TLC.

Reason for Karma (Optional)
Successfully updated karma reason!
June 14, 2011 1:49:36 PM from WinCustomize Forums WinCustomize Forums

Quoting Xiandi,
Iconpackager is definitely in need of some TLC.

Word.

Reason for Karma (Optional)
Successfully updated karma reason!
June 17, 2011 8:10:22 AM from WinCustomize Forums WinCustomize Forums

No answer besides the automatical one yet.

Reason for Karma (Optional)
Successfully updated karma reason!
June 17, 2011 8:52:16 AM from WinCustomize Forums WinCustomize Forums

Carl. Come on... x number of people tasked to y projects. It's just a matter of time until it gets done. 

The complaining doesn't help hasten to issue's resolution. Sometimes a pm to management (*use care here) helps remind... tactfully.

You know I have your best interest at heart. 

Reason for Karma (Optional)
Successfully updated karma reason!
June 17, 2011 9:13:23 AM from WinCustomize Forums WinCustomize Forums

Okay, patience. But this was not as bad meant as it may sound. Others do a 'Bump'.

 

Nevertheless I will wait and see if I can work arround the issue.

Reason for Karma (Optional)
Successfully updated karma reason!
June 30, 2011 2:46:02 AM from WinCustomize Forums WinCustomize Forums

Copy of report made to support [#SXH-324381]:

This is what I did :

-          Copy IconPackage

-          Loaded and applied the copy

-          Changed some icons, especially file icons

-          Saved Package

-          Applied package

 

Result : Pic 2 + 3. A lot of the icons are messed up and are not assigned to the subject they should / they where on saving though).

Note even the Shortcut Icon is messed up.

 

 

Pic 1 shows a slight error where IP-undefined file types juat grab the shield icon.

 

My suspect is that icon packager messes up the ordering while saving.

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
June 30, 2011 5:27:26 PM from WinCustomize Forums WinCustomize Forums

Quoting c242,
Quoting WebGizmos,
reply 3
IconPackager doesn't seem to work right with Windows 7.

Is that a common known problem ? I mean if such an essential function like updating and saving a package is broken, a fix would be in order.

All I can say Carl is that IconPackager worked ok on my XP rig...but ever since I've been using Windows 7 it never works right...I can't change icons and even when I don't and use a regular icon package it never "sticks" and my icons revert back to default icons...very annoying.

Reason for Karma (Optional)
Successfully updated karma reason!
July 1, 2011 6:05:04 AM from WinCustomize Forums WinCustomize Forums

What I wonder about is that support never seemed to have heard of this issue (?).

Reason for Karma (Optional)
Successfully updated karma reason!
July 9, 2011 10:04:47 AM from WinCustomize Forums WinCustomize Forums

BUMP.

Reason for Karma (Optional)
Successfully updated karma reason!
July 21, 2011 4:56:16 AM from WinCustomize Forums WinCustomize Forums

BUMP²

Reason for Karma (Optional)
Successfully updated karma reason!
July 21, 2011 7:30:01 AM from WinCustomize Forums WinCustomize Forums

Happening to me as well. I think we'll have a bit to wait before they get to it, though.

You might try to catch someone in irc... to remind.

Reason for Karma (Optional)
Successfully updated karma reason!
July 21, 2011 9:18:21 AM from WinCustomize Forums WinCustomize Forums

I wonder how people still manage to build packages. All on XP or Vista 32bit ? On the other hand we haven't had so much packages the last months...

Reason for Karma (Optional)
Successfully updated karma reason!
July 21, 2011 10:25:02 AM from WinCustomize Forums WinCustomize Forums

Carl. You are not forgotten.  

Reason for Karma (Optional)
Successfully updated karma reason!
July 21, 2011 10:50:08 AM from WinCustomize Forums WinCustomize Forums

I also have been having the same issues with IP on my Windows 7 x64 system. Folder icons especially have a tendancy to revert back to default for no reason. There have even been instances where I can't get an icon to change and have gone as far as removing it from the pack completely to get rid of it, and believe it or not, it still displays !!!!! That's just crazy !!! Some of my icons won't even display correctly, particularly the shadow effects of some 3D type icons. As a previous poster stated, I too never had an issue with IP until I upgraded to Windows 7. I certainly hope they can come up with a patch to resolve these issues, as I really love to use IP.

Reason for Karma (Optional)
Successfully updated karma reason!
July 21, 2011 3:36:35 PM from WinCustomize Forums WinCustomize Forums

Quoting Zubaz,
Carl. You are not forgotten.  

 

Thanks Zu.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #101114  walnut1   Server Load Time: 00:00:00.0000843   Page Render Time:

Home | About | Privacy | Upload Guidelines | Terms of Service | Help
WinCustomize © 2014 Stardock Corporation. All Rights Reserved.