Windowblinds 7 Latest version broke on Windows XP

Windowblinds 7 Latest version broke on Windows XP

By on May 13, 2011 4:33:17 AM from Stardock Forums Stardock Forums

chockimon

Join Date 10/2008
0

Since installing Windowblinds 7.2c, I've had nothing but problems with skin corruption. Basically none of the skins work anymore under Windows XP. They appear to work at first but after about 5 minutes or so, the menus and borders become corrupt. I've uninstaled and reinstalled and I've even reinstalled Windows XP, but the problem remains, so I can only assume the problem is with the latest version of Windowblinds, as it worked ok before I updated.

Is there anyway to install a previoius version. Iif so how, because I don't see a way using impulse.

 

Thanks

 [

28 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2011 9:34:38 AM from WinCustomize Forums WinCustomize Forums

you can do it if you archived previous versions

I dont have the latest impulse installed, but there was an option to not show pre-release/beta versions so you saw the last full release version

Reason for Karma (Optional)
Successfully updated karma reason!
May 13, 2011 5:34:24 PM from Stardock Forums Stardock Forums

I tried that, but it's just showing the latest version which doesn't work.

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 6:11:13 AM from Stardock Forums Stardock Forums

Well it looks like I'm stuck with a useless version of Windowblinds 7. The problem definitely lies with WIndowblinds 7.2, as version 7.1 worked perfectly. Unfortunately I didn't archive version 7.1, so I can't go back to an earlier version and Stardock won't send me this version, only the latest version 7.2c, which doesn't work, as every skin is corrupt, even the derfault ones. Can anyone else help me out. Thanks!

 

Reason for Karma (Optional)
Successfully updated karma reason!
Sign Up or Login and this ad disappears!
There are many great features available to you once you register. Sign Up for a free account and browse the forums without ads.
June 9, 2011 6:28:48 AM from WinCustomize Forums WinCustomize Forums

For what it's worth, I'm running the current 7.2c on XP and it's fine, didn't have to do anything special with it.

Go to your WBConfig window, About Windowblinds tab, click on the "Copy to clipboard" button, and paste that here.  I won't have a clue what to do with it, but other people here do.  Also, need to tell them which version of XP you have - Home 32bit, Pro 32bit, or Pro 64bit.

Another generic suggestion - if your video drivers are ancient you might want to update them if you can.

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 6:48:36 AM from WinCustomize Forums WinCustomize Forums

There's really nothing to be done by yourself since you didn't archive... unless... you perhaps backed up your hard disk before going to 7.2 (c).

I note you're a current customer(4), and you've been a member for almost 3 years. Were I you, I'd write to support@stardock.com to see if they can help you.

There are one or two tricks you might not have tried...

1. Open Impulse and under "My Software" single click on WB7 and them press "Shift + right click". A submenu should appear. Choose "Verify Installation". If the choice isn't there, close the submenu that did appera and try again.. shift and right click. This should either give you (after it's run) WB& correctly or incorrectly installed. If "Correctly installed" then go to 2. If not (and I'm betting on this) then do the update and reboot.

If WB7 was correctly installed: 

2. In Impulse -> Preferences and under general, untick pre-release versions if it's ticked, and then click OK and close Impulse. Then restart Impulse and it should show an update for WB7. Update it and it should revert you to the prior released version of WB, after reboot.

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 9:00:48 AM from Stardock Forums Stardock Forums

I'm using the latest Nvidia drivers 275.27. I did a fresh install of Windows XP and the first thing I did was install Windowblinds 7 and the skins are still corrupt, so I'm clueless as to what's causing it. But thanks anyway. Here's my Windowblinds info.

WindowBlinds version : WindowBlinds 7.2 (build 95 x86)

 WindowBlinds is installed correctly on this PC
WindowBlinds appears to be activated on this PC
Your machine supports per pixel borders on WindowBlinds skins.
 
(BenQ G2420HDBL (Digital)) 1 is attached to NVIDIA GeForce GTX 260
 
Wblind.dll      2011/02/01 20:51:20
Wbsrv.dll      2010/04/01 16:44:56
SevenConfig.exe      2011/03/29 16:34:52
Wbload.exe      2010/09/07 22:02:35
Wbhelp.dll      2010/09/07 22:02:34
Wbui.dll      2010/04/01 16:44:05
Tray.dll           2010/04/01 16:44:19
Screen.exe      2010/05/26 16:18:43
Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 9:09:56 AM from WinCustomize Forums WinCustomize Forums

Did you have your firewall/antivirus off during the download and installation?

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 9:10:23 AM from Stardock Forums Stardock Forums

I verified the installation and everything is ok and I then did as you said, but the only version available is 7.2 which is what's causing problems. For some reason 7.2c and 7.2 will not work. Like I said, 7.1 worked without any problems. I guess I'll just have to wait to see what Stardock support says.  

I did a fresh install of Windows XP and Windowblinds was the first thing I installed. The skins seem ok at first after I apply them, but then after about 5 mintues they start becoming corrupt. The only firewall that was installed was the windows default firewall, So i don't think it's Kaspersky 2011 that's causing the problem. The only thing I installed when the problem first started was a Bluetooth wireless USB device. I have since removed it it and uninstalled the drivers and the problem remains. I've tried everything and I haven't a clue what could be causing it. Thanks anyway.

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 10:38:57 AM from WinCustomize Forums WinCustomize Forums

The best thing to do is perhaps open task manager and take a look at the processes tab. If you can, see what process starts as the blind becomes corrupted. This should (hopefully) lead to the software causing the problem...

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 10:55:48 AM from WinCustomize Forums WinCustomize Forums

Quoting chockimon,
The skins seem ok at first after I apply them, but then after about 5 mintues they start becoming corrupt.

I think that's the salient point.  First they work correctly...but later they don't.

It can only be some other process interfering then/later ....or perhaps its card driver related.  Is the driver version the same as when you were running the earlier WB OK?

If not, then it may be worth 'rolling back' and see what happens...

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 4:03:51 PM from Stardock Forums Stardock Forums

I was using an earlier Nvidia driver, but I would rather not go back to an earlier driver as I play a lot of games, some of which are only compatible with the latest driver. I guess if I want to daignose what the problem is I might have no choice but to install an earlier driver, just to see whether the problem still occurs.

I've been messing about for the last eight hours trying to work out what's causing the problem. I closed down every program and every running process that I could in the task manager and left the task manager open so that I could monitor any programs that might start up in the background. But I'm not seeing anything that might be causing the problem. One thing I have noticed is that as soon as I run Firefox 4 the skin becomes corrupt straight away. Could firefox 4 cause skin corruption even if it's not running? I've also noticed the same happens with Avant Browser, as soon as I start to play a Youtube video. I've also tried running a few games and as soon as the games start the skin also becomes corrupt, so it definitely seems like it could be the latest 275 drivers that are causing the skin corruption problems.

Is anyone else using Windowblinds 7.2c with Windows XP and the latest 275 drivers?

 

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 4:37:21 PM from WinCustomize Forums WinCustomize Forums

Quoting chockimon,
Is anyone else using Windowblinds 7.2c with Windows XP and the latest 275 drivers?

No I'm on ATI.  What you're describing sure makes me wonder about the video drivers, I'd try going back to the earlier version.  Before doing that, I'd right-click on the WindowBlinds systray icon, select "Unload Windowblinds", and try running some of the apps you're having trouble with while WB isn't loaded, just out of curiosity.  Sounds like the drivers may be hinky.

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 4:46:05 PM from WinCustomize Forums WinCustomize Forums

I also see this-

Your Wblind.dll file is date-stamped 2011/02/01, mine is date-stamped 2010/11/29.  I don't know what the "right" answer is, seems like yours would be.  Saw the difference and thought I'd throw it out here.  All of the other date-stamps are the same, with different time-stamps.

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 4:48:54 PM from WinCustomize Forums WinCustomize Forums

Could be a driver issue... won't know until it reverts to an earlier WB, though.

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 5:41:38 PM from Stardock Forums Stardock Forums

Well I went back to Nvidia Geforce drivers 267.24 and I'm still getting the skin corruption. Surely the problem must lie with Windowblins 7.2 then? Anyone else using Windowblinds 7.2c and Windows XP with a Nvidia Graphics card and having the same problems?

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 5:53:57 PM from WinCustomize Forums WinCustomize Forums

Now maybe you'll try the Impulse tricks I mentioned in Reply #5?

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 6:18:40 PM from Stardock Forums Stardock Forums

Just tried that now, but only showed version 7.2. I installed it anyway and rebooted, but I'm still getting the same problem.

WindowBlinds version : WindowBlinds 7.2 (build 95 x86)

WindowBlinds is installed correctly on this PC
WindowBlinds appears to be activated on this PC
Your machine supports per pixel borders on WindowBlinds skins.
 
(BenQ G2420HDBL (Digital)) 1 is attached to NVIDIA GeForce GTX 260
 
Wblind.dll      2010/11/29 19:40:20
Wbsrv.dll      2010/04/01 22:40:56
SevenConfig.exe      2010/11/29 19:40:27
Wbload.exe      2010/11/29 19:40:35
Wbhelp.dll      2010/11/29 19:40:34
Wbui.dll      2010/04/01 22:40:05
Tray.dll           2010/04/01 22:40:19
Screen.exe      2010/06/07 20:10:43
 
Starting to look like I was right all along. It's got to be a bug in Windowblinds 7.2. But unless I can try 7.1 again I won't know for sure.
Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 6:39:28 PM from WinCustomize Forums WinCustomize Forums

Quoting chockimon,
I did a fresh install of Windows XP and the first thing I did was install Windowblinds 7

This statement causes me to think that maybe XP isn't fully updated.  What version of .Net do you have installed?

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 9:01:42 PM from WinCustomize Forums WinCustomize Forums

Generally speaking rapid corruption like that would be caused by something leaking a considerable amount of GDI resources or video drivers corrupting bitmaps.

If you open taskmanager and enable the option to show GDI objects on the processes tab you may be able to see if anything is using unusually large amounts of GDI objects.

Reason for Karma (Optional)
Successfully updated karma reason!
June 9, 2011 9:03:41 PM from WinCustomize Forums WinCustomize Forums

Quoting BigDogBigFeet,



Quoting chockimon,
reply 6
I did a fresh install of Windows XP and the first thing I did was install Windowblinds 7


This statement causes me to think that maybe XP isn't fully updated.  What version of .Net do you have installed?

Actually WindowBlinds does not and never has used .net and does not care what version (if any) is installed.  Impulse uses .Net 2.0 but if that were missing Impulse would not even start.

I would make sure the machine is running XP SP2 or later though.

Reason for Karma (Optional)
Successfully updated karma reason!
June 10, 2011 9:44:14 AM from Stardock Forums Stardock Forums

This is really beginning to do my head in, lol.  Thanks for the input anyway. I always keep my computer up to date using windows update. All my drivers, .Net, etc. Since I couldn't get a hold of windowblinds 7.1, I uninstalled and went back to Windowblinds 6.4 and exactly the same thing is happening. I've uninstalled the latest Nvidia drivers, Firefox 4, Avant browser and no difference. One thing I have noticed is that as soon as I play a video the skin becomes corrupt immediately. For example when I play a youtube video. I uninstalled and reinstalled flash and still the same.

Hi Neil, DrJBHL suggested something similar and I turned on all options in task manager and stared at the screen for 1 hour and no corruption occurred. I then opened Avant Browser and played a Youtube Video and the corruption occurred immediately, but I didn't notice anything unusual in the task manager. So I just do not know what could be causing this. I have a dual boot system with Windows 7 and I have no problems with Windows 7 x64 whatsoever, even though I tend to install the exact same software on both. This has got me stumped.

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
June 10, 2011 9:53:09 AM from WinCustomize Forums WinCustomize Forums

When you get rid of Avantbrowser, does it still occur (or if you "except" it from WB)?

Reason for Karma (Optional)
Successfully updated karma reason!
June 10, 2011 2:20:17 PM from Stardock Forums Stardock Forums

I uninstalled Avant Browser and it's still doing it. Even went back to Windowblinds 6.4 and still getting the same problem.

Reason for Karma (Optional)
Successfully updated karma reason!
June 10, 2011 2:34:55 PM from WinCustomize Forums WinCustomize Forums

bizarre problem.

Is your RAM ok?

Reason for Karma (Optional)
Successfully updated karma reason!
June 10, 2011 4:44:08 PM from WinCustomize Forums WinCustomize Forums

Another thought kind of along those lines-

Sounds like something could be getting hot, particularly CPU or video chipset.  Fans working and reasonably clean?  Heatsinks reasonably clean? (Have to really get in there and look at that video heatsink).

Edit- Just now saw that your dual boot Win7 is fine, more likely to be in the software, (oops/duh).  Anyway nothing wrong with a little dirt-reminder.

Another Edit- Are you running 64bit XP?

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108433  walnut3   Server Load Time: 00:00:00.0000812   Page Render Time:

Home | About | Privacy | Upload Guidelines | Terms of Service | Help
WinCustomize © 2014 Stardock Corporation. All Rights Reserved.