Cursor FX 2.02 Interoperability Issues (Windows 7, Screenshots, Chrome, Virtual PC, CursorXP)

By on December 14, 2009 8:42:52 PM from WinCustomize Forums WinCustomize Forums

soja

Join Date 10/2003
0

Hi,

After some time using Cursor FX 2.02, I've noticed some issues.  (These likely exist in previous versions as well, but 2.02 is what I purchased.)

 

  1. In Windows 7, when Aero hides other windows--e.g. Show Desktop "Peek" (lower-right corner) or e.g. clicking on an app with multiple windows open in the taskbar and then hovering over one so that its window is previewed--the cursor disappears.
    • (One interesting note is that when I try to reproduce with Win+Tab, I notice that the default Windows cursor comes back for the duration of the switch.  Is this a workaround in Cursor FX that hooks into the Win+Tab keypress?  If so, will all of these types of issues where Windows hides other UI need a similar hack?)
  2. When I take a screenshot (either via the Prt Scr key, or through other software methods like the Win7 Snipping Tool), the Cursor FX cursor ends up in the screenshot.  The normal windows cursor does not.
  3. In Chrome browser, it is virtually impossible to successfully drag a tab to another location in the tab bar, or into other Chrome window, while Cursor FX is running.  It never seems to "lock on" and allow me to drop between two other tabs.  When I disable Cursor FX, it works perfectly.
  4. In Windows Virtual PC (i.e. 2009 release) using a Vista client OS (though it may not matter that it's Vista), the Cursor FX cursor appears with an opaque black box above the cursor, partially obscuring it.  I would estimate that it's about 35x35 px.  It stays the same size, regardless of whether I choose a larger/smaller Windows or Cursor FX cursor.
  5. Previewing the MousePill Cursor XP Theme in Cursor FX causes Cursor FX to hang.  Theme Editor also hangs when loading the MousePill theme.
  6. The Text Select cursor of MousePill disappears after briefly showing the cursor for a split-second.  The only way to get the cursor back is to move it elsewhere (outside of a text area) or click, whereupon it shows the mousedown image very briefly, then disappears again.  Perhaps a MousePill issue--or perhaps an issue interpreting CurXPTheme format in Cursor FX 2.02.  Can someone help me figure it out please?

 


I would be grateful to know whether there are any workarounds or fixes planned.  Are these known issues?

Thank you.

8 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
December 14, 2009 9:40:01 PM from WinCustomize Forums WinCustomize Forums

I'm sure the developer's appreciate the information.

It might be better for them if you continue to post to just one thread.

CursorFX has not yet been released for Windows 7.

from the product page.......


System Requirements
Minimum:
  • Windows XP (32-bit) or Vista (32-bit)
  • 100 MB free drive space
  • 512 MB RAM
Reason for Karma (Optional)
Successfully updated karma reason!
December 16, 2009 12:07:01 AM from WinCustomize Forums WinCustomize Forums

CursorFX has not yet been released for Windows 7.

Hmm, OK.  Well, I wasn't cognizant of that.  At any rate, only issue #1 is limited to Windows 7.  The rest are reproducible in Vista.

 

It might be better for them if you continue to post to just one thread.

Is that why my initial thread regarding MousePill got nuked?  I was wondering whether I had broken some rule or something.  I thought the issue was different enough...and it would have been nice not to have to remember and duplicate everything I wrote before on it...but oh well.  I'll add a couple notes to the list above.

 

Above all, I would like to know why the text cursor of MousePill keeps disappearing.  I assume the CurXPTheme is not configured correctly, but I'm not sure how.  It's hard to go investigating especially when Theme Editor keeps freezing when I have MousePill loaded.

Reason for Karma (Optional)
Successfully updated karma reason!
December 16, 2009 8:42:37 AM from WinCustomize Forums WinCustomize Forums

I assume the CurXPTheme is not configured correctly

That's my thought as well. However, it may work fine under CursorXP. I'm one of the people who moderate the cursor gallery and I've run across a few that cause system instability/lockups.

 

Is that why my initial thread regarding MousePill got nuked?

We don't nuke threads. We do "hide" some if they are SPAM or exceptionally profane. I checked and this is the only post under your profile.....it may have fallen thru the matrix during a server burp.

 

Reason for Karma (Optional)
Successfully updated karma reason!
Sign Up or Login and this ad disappears!
There are many great features available to you once you register. Sign Up for a free account and browse the forums without ads.
December 20, 2009 9:45:21 PM from WinCustomize Forums WinCustomize Forums

it may have fallen thru the matrix during a server burp.

Yeah, that's weird.  It was there for a couple hours, then I went to refresh the forum, and it was gone.  I went back in my browser and refreshed the page, and that's when it said it couldn't find the thread anymore.

Anyway, I went poking around and was able to kinda fix issue #6.  I wasn't sure exactly what I was doing as I've never edited a theme and didn't have any docs.  In case anybody else wants it, here's what I did:

 

  1. Rename Mousepill.CurXPTheme to Mousepill.zip and extract contents
  2. Edit IBeam.png (I used Paint.NET since it plays nice with PNG transparency)
    1. Resize Canvas to 19 pixels width (from 38), effectively removing the second frame.
    2. Save
  3. Edit IBeam_Down.png
    1. Copy frame #2 (rightmost 19-pixels) and move over frame #1 (left side)
    2. Resize Canvas to 19 pixels width (from 38), effectively removing the second frame.
    3. Save
  4. Edit Scheme.ini in text editor (e.g. notepad)
  5. Delete the IBeam_Script and IBeam_Down_Script sections (two lines each)
  6. In each of the IBeam and IBeam_Down sections...
    1. Set Frames=1
    2. Set Framescript=0
    3. (Maybe I didn't have to edit the images, and could have just changed these values to 1,0 and 1,1--I didn't try it, so I don't know.  It didn't occur to me until afterwards.)
  7. Save Scheme.ini
  8. Zip up the contents and rename from .zip to .CurXPTheme, then load it in Cursor FX.
Voila.  It still causes CursorFX to hang in preview mode, though.  =\

 

Reason for Karma (Optional)
Successfully updated karma reason!
December 20, 2009 9:57:04 PM from WinCustomize Forums WinCustomize Forums

What is the user experience for that machine? Plus what graphics do you have? Such as Nvidia or ATI...?

Reason for Karma (Optional)
Successfully updated karma reason!
December 20, 2009 10:10:31 PM from WinCustomize Forums WinCustomize Forums

Mine?

Experience Index = 5.8

NVIDIA GeForce 8800 GT

Reason for Karma (Optional)
Successfully updated karma reason!
December 20, 2009 10:18:31 PM from WinCustomize Forums WinCustomize Forums

What happens with a different cursor? Such as with this one here LINK

Reason for Karma (Optional)
Successfully updated karma reason!
December 21, 2009 1:30:22 AM from WinCustomize Forums WinCustomize Forums

What issue number (from above) do you want me to check out/report on?

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #101114  walnut1   Server Load Time: 00:00:00.0000391   Page Render Time:

Home | About | Privacy | Upload Guidelines | Terms of Service | Help
WinCustomize © 2014 Stardock Corporation. All Rights Reserved.